We have detected timeouts while creating patients via API

Incident Report for Fuze Health

Resolved

This incident was resolved.
Posted Feb 08, 2023 - 10:05 PST

Investigating

We are working on the incident with highest priority
Posted Feb 08, 2023 - 09:47 PST