Delayed communication between internal systems

Incident Report for Fuze Health

Resolved

As of 12:05pm EDT, the team has rolled back the release that was causing the delay of communication between Truepill Dashboard and our pharmacy fulfillment system. Systems appear to behaving normally and communication time has recovered.
Posted Apr 10, 2025 - 09:42 PDT

Identified

We have identified an issue within our pharmacy systems causing a delay in syncing data between our Truepill Dashboard and pharmacy fulfillment system. The team is working on rolling back a release.
Posted Apr 10, 2025 - 09:25 PDT
This incident affected: Pharmacy Systems and Truepill Dashboard.