Important Notice: Services Temporarily Unavailable

Incident Report for Fuze Health

Resolved

This incident has been resolved.
Posted Sep 27, 2024 - 11:46 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2024 - 08:50 PDT

Investigating

We are currently investigating an issue. All systems are affected.
Posted Sep 27, 2024 - 08:10 PDT