Important Notice: Services Temporarily Unavailable

Incident Report for Fuze Health

Resolved

This incident has been resolved.
Posted May 29, 2024 - 15:36 PDT

Monitoring

Pharmacy API service appears to be restored. We are monitoring the service.
Posted May 29, 2024 - 11:30 PDT

Investigating

We regret to inform you that our site is currently experiencing technical difficulties and is temporarily unavailable. Our team is working diligently to resolve the issue and restore service as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted May 29, 2024 - 09:46 PDT